毎日の困りごと、すぐ解決。

日本

サブネット計算

IPアドレスをプレフィックス(192.168.1.10/24)かサブネットマスク(255.255.255.0)付きで入力すると、ネットワーク、ブロードキャスト、最初と最後のホスト、ホスト数がすぐにわかります。IPv4とIPv6に対応。

ネットワーク
—
サブネットマスク
—
ワイルドカードマスク
—
ブロードキャスト
—
最初のホスト
—
最後のホスト
—
使用可能なホスト数
—
種類
—

サブネットに分割

計算結果は目安です。Solvemisは、計算結果およびその利用について一切の責任を負いません。

Solvemisは無料・登録不要です。お役に立てたなら、応援していただけるとうれしいです。 コーヒーをおごる

しくみ

使い方

  1. IPアドレスを入力します。後ろにプレフィックス(/24)かサブネットマスク(255.255.255.0)を付けてもかまいません。
  2. 付けない場合は、一覧からプレフィックスを選びます。横にマスクが表示されます。
  3. 表でネットワーク、マスク、ブロードキャスト、ホスト範囲を確認します。
  4. ネットワークを分けたいときは「サブネットに分割」を開き、サイズを選びます。

計算方法

ネットワークアドレスはアドレスとマスクのビットごとのAND、ブロードキャストはホスト部をすべて1にしたものです。プレフィックスとマスクはCIDR(RFC 4632)、/31はRFC 3021、IPv6はRFC 4291、/127はRFC 6164、IPv6の短縮表記はRFC 5952に従います。アドレスの種類はIANAの特殊用途アドレス登録簿(RFC 6890)とRFC 1918によります。

出典

この計算ツールについて

プレフィックス付きアドレスの読み方

192.168.1.10/24 の /24 は、左から何ビットが ネットワーク部 かを表します(32ビット中24ビット)。残りの8ビットが ホスト部(機器)です。サブネットマスクは同じことを別の形で書いたもので、1が24個と0が8個、つまり 255.255.255.0 です。

結果の下の図は、アドレスを2進数で表示し、ネットワーク部を青で示しています。

計算できること

  • ネットワーク:ブロックの最初のアドレス(ホスト部がすべて0)。
  • ブロードキャスト:最後のアドレス(ホスト部がすべて1)。
  • 最初と最後のホスト:機器に割り当てられる範囲。
  • 使用可能なホスト数:2^(32−プレフィックス)−2。
  • ワイルドカードマスク:ACLで使う反転マスク。
  • 種類:グローバル、プライベート、CGNAT、ドキュメント用など。旧クラスも表示。

よく使うIPv4プレフィックス

プレフィックス サブネットマスク ホスト数
/8 255.0.0.0 16,777,214
/16 255.255.0.0 65,534
/24 255.255.255.0 254
/26 255.255.255.192 62
/28 255.255.255.240 14
/30 255.255.255.252 2
/31 255.255.255.254 2 (ポイントツーポイント)
/32 255.255.255.255 1

サブネットに分割する

プレフィックスを1ビット増やすごとに、ネットワークは2つに分かれます。/24を/26に分けると、64アドレス(ホスト62台)のサブネットが4つできます。「サブネットに分割」を開いてサイズを選んでください。

プライベートアドレスと特殊なアドレス

家庭や会社のアドレスは、ふつう プライベートアドレス(RFC 1918)です:10.0.0.0/8、172.16.0.0/12、192.168.0.0/16。ルーターのIPが 100.64.0.0/10 の範囲なら、プロバイダーの CGNAT の内側にいます。自分のIPは IPアドレス確認 で確認できます。

IPv6

IPv6アドレスは128ビットで、16進数で書きます。短縮表記(:: 付き)と完全な表記の両方を表示します。ブロードキャストはなく、LANは常に/64です。

よくある質問

/24のホスト数はいくつですか?

254です。/24には256個のアドレスがありますが、最初がネットワークアドレス、最後がブロードキャストアドレスなので、機器に使えるのは254個です。一般にプレフィックスnのIPv4ネットワークのホスト数は2^(32−n)−2です(/31と/32を除く)。

ワイルドカードマスクとは?

サブネットマスクのビットを反転したものです。255.255.255.0なら0.0.0.255。CiscoルーターのACLやOSPFで使われます。

/31でホストが2つ使えるのはなぜ?

ルーター同士をつなぐ回線では、ネットワークアドレスもブロードキャストも必要ないからです。RFC 3021で、/31の2つのアドレスをホストとして使うことが認められています。

IPv6ではどうなりますか?

IPv6にはブロードキャストがなく、ブロック内のアドレスはすべて使えます。LANには/64、ユーザーには/48か/56を割り当てるのが一般的です。ルーター間には/127が推奨されています(RFC 6164)。

2026年10月2日 更新

このツールに足りない機能や、ほしいツールはありますか? ご意見を送る